Easysoft ODBC-Salesforce Driver

How do I connect QlikView to Salesforce.com?

Article:
01077
Last Reviewed:
7th August 2014
Revision:
1

Use the Salesforce.com ODBC Driver to connect QlikView Desktop to Salesforce.com and provide real time access to your Salesforce.com objects, enabling you to analyse Salesforce.com data from your QlikView documents.

The Salesforce.com ODBC Driver is available to download from the Easysoft web site:

  1. Download the Windows Salesforce.com ODBC Driver. (Registration required.)
  2. Install and license the Salesforce.com ODBC Driver on the machine where QlikView is installed.

    For installation instructions, see the Salesforce.com ODBC Driver documentation.

Before you can use the Salesforce.com ODBC Driver to connect QlikView to Salesforce, you need to configure an ODBC data source. An ODBC data source stores the connection details for the target database (e.g. Salesforce.com) and the ODBC driver that is required to connect to it (e.g. the Salesforce.com ODBC driver).

You can configure a User ODBC data source, which is only available to the user who creates it, or a System ODBC data source, which is available to all users on the machine. You configure ODBC data sources in ODBC Administrator, which is included with Windows.

To run ODBC Administrator on 32-bit Windows, open Administrative Tools in Control Panel, and then open Data Sources (ODBC). (On older versions of Windows, the Control Panel applet that launches ODBC Administrator is labelled Data Sources.)

To run ODBC Administrator on 64-bit Windows, in the Windows Run dialog box, type:

%windir%\syswow64\odbcad32.exe

If you are not sure whether your version of Windows is 32-bit or 64-bit, follow the instructions for running ODBC Administrator on 64-bit Windows. If you get an error, follow the instructions for 32-bit Windows instead.

Use ODBC Administrator to create your Salesforce.com ODBC Driver data source:

  1. Do one of the following:
    • To create a User data source, in the User DSN tab, choose Add.

      –Or–

    • To create a System data source, choose the System DSN tab, and then choose Add.
  2. In the Create New Data Source dialog box, choose Easysoft ODBC-Salesforce Driver, and then choose Finish.
  3. Complete the Easysoft ODBC-Salesforce Driver DSN Setup dialog box:
    SettingValue
    DSNSalesforce.com
    User NameThe name of your Salesforce.com user. For example, myuser@mydomain.com.
    PasswordThe password for your Salesforce.com user.
    TokenThe security token for your Salesforce.com user, if required.

    To find out whether you need to supply a security token, choose the Test button. If the connection attempt fails with an error which contains LOGIN_MUST_USE_SECURITY_TOKEN, you need to supply one.

    Salesforce.com emails the security token to the email address associated with your Salesforce.com user account. If you have not received a security token, you can regenerate it. Salesforce.com will then email the new security token to you. To regenerate your security token, log in to Salesforce.com and then choose Setup from the user menu. Search for "security token" in the Quick Find box. Click Reset Security Token in the Reset Security Token page. When you receive the token in your email client, copy it and then paste it into the Token field.

  4. Use the Test button to verify that you can successfully connect to Salesforce.com.

You can now connect QlikView to Salesforce.com:

  1. In QlikView, open a QlikView document or create a new one.
  2. On the File Menu, choose Edit Script.

    The Edit Script dialog box is displayed.

  3. In the Data tab, choose ODBC from the Database list.

    Note On 64-bit Windows, the Data tab contains a Force 32 Bit check box. This is provided for ODBC drivers where only a 32-bit version is available. You can leave this check box clear when using the Salesforce ODBC driver. (If Force 32 Bit is selected, you will still be able to use the Salesforce ODBC driver, as the driver distribution includes both a 32-bit and a 64-bit ODBC driver. However, System data sources configured in the 64-bit ODBC Administrator will not be visible.)

  4. Choose the Connect button.

    The Connect to Data Source dialog box is displayed.

  5. Choose your ODBC Data Source from the list and then choose OK.

    If your ODBC Data Source is not listed, choose Show User DSNs.

  6. In the Edit Script dialog box, choose the Select button.

    The Create Select Statement dialog box is displayed.

  7. In the Database Tables list, choose the Salesforce table that contains the data you want to retrieve.
  8. To retrieve a subset of the fields in this table, choose the fields you want in the Fields list. Otherwise, skip this step.
  9. QlikView recommend that the Preceding Load check box is selected. Choose OK.
  10. In the Edit Script dialog box, choose Reload.

    If this is a new document you will be prompted to save the document at this stage.

  11. If necessary, use the Close button to dismiss the Script Execution Progress message box, when QlikView has finished retrieving the Salesforce data.

    The Sheet Properties dialg box is displayed.

  12. Use either the Add or the Add All Button to display the Salesforce fields you want in your QlikView document. Choose OK.
Applies To

Knowledge Base Feedback

* Did this content help you?
* Please select one option based on your first choice:

(* Required Fields)